What’s Vulnerable › Vulnerabilities
CVE-2022-2361: Social Chat < 6.0.5 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Social Chat WordPress plugin before 6.0.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks.
Affected products
- WP Social Chat – Click To Chat App: before 6.0.5 — fixed in 6.0.5
How to fix
Upgrade to a fixed version: WP Social Chat – Click To Chat App 6.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/aa69377d-ba9e-4a2f-921c-be2ab5edcb4e
- https://wpscan.com/vulnerability/aa69377d-ba9e-4a2f-921c-be2ab5edcb4e
Get alerted when CVE-2022-2361 or the next vulnerability affects your stack