What’s Vulnerable › Vulnerabilities
CVE-2022-23623: Validation bypass in frourio
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-20
Description
Frourio is a full stack framework, for TypeScript. Frourio users who uses frourio version prior to v0.26.0 and integration with class-validator through `validators/` folder are subject to a input validation vulnerability. Validators do not work properly for request bodies and queries in specific situations and some input is not validated at all. Users are advised to update frourio to v0.26.0 or later and to install `class-transformer` and `reflect-metadata`.
Affected products
- frouriojs frourio: before 0.26.0 — fixed in 0.26.0
How to fix
Upgrade to a fixed version: frouriojs frourio 0.26.0. Check the vendor advisory for mitigations.
References
- https://github.com/frouriojs/frourio/commit/7c19ac5363305b81b1c6b5232620228763d427af
- https://github.com/frouriojs/frourio/security/advisories/GHSA-8xxm-h73r-ghfj
- https://github.com/frouriojs/frourio/commit/7c19ac5363305b81b1c6b5232620228763d427af
- https://github.com/frouriojs/frourio/security/advisories/GHSA-8xxm-h73r-ghfj
Get alerted when CVE-2022-23623 or the next vulnerability affects your stack