What’s Vulnerable › Vulnerabilities
CVE-2022-23624: Validation bypass in frourio-express
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-20
Description
Frourio-express is a minimal full stack framework, for TypeScript. Frourio-express users who uses frourio-express version prior to v0.26.0 and integration with class-validator through `validators/` folder are subject to a input validation vulnerability. Validators do not work properly for request bodies and queries in specific situations and some input is not validated at all. Users are advised to update frourio to v0.26.0 or later and to install `class-transformer` and `reflect-metadata`.
Affected products
- frouriojs frourio-express: before 0.26.0 — fixed in 0.26.0
How to fix
Upgrade to a fixed version: frouriojs frourio-express 0.26.0. Check the vendor advisory for mitigations.
References
- https://github.com/frouriojs/frourio-express/commit/73ded5c6f9f1c126c0cb2d05c0505e9e4db142d2
- https://github.com/frouriojs/frourio-express/security/advisories/GHSA-mmj4-777p-fpq9
- https://github.com/frouriojs/frourio-express/commit/73ded5c6f9f1c126c0cb2d05c0505e9e4db142d2
- https://github.com/frouriojs/frourio-express/security/advisories/GHSA-mmj4-777p-fpq9
Get alerted when CVE-2022-23624 or the next vulnerability affects your stack