What’s Vulnerable › Vulnerabilities
CVE-2022-23634: Information Exposure when using Puma with Rails
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-11 · updated 2026-06-17
- Weakness: CWE-200
Description
Puma is a Ruby/Rack web server built for parallelism. Prior to `puma` version `5.6.2`, `puma` may not always call `close` on the response body. Rails, prior to version `7.0.2.2`, depended on the response body being closed in order for its `CurrentAttributes` implementation to work correctly. The combination of these two behaviors (Puma not closing the body + Rails' Executor implementation) causes information leakage. This problem is fixed in Puma versions 5.6.2 and 4.3.11. This problem is fixed in Rails versions 7.02.2, 6.1.4.6, 6.0.4.6, and 5.2.6.2. Upgrading to a patched Rails _or_ Puma version fixes the vulnerability.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 35, 36, 37
- puma: before 4.3.11; from 5.0.0 before 5.6.2 — fixed in 4.3.11, 5.6.2
- Ruby on Rails: from 5.0.0 before 5.2.6.2; from 6.0.0 before 6.0.4.6; from 6.1.0 before 6.1.4.6; from 7.0.0 before 7.0.2.2 — fixed in 5.2.6.2, 6.0.4.6, 6.1.4.6, 7.0.2.2
- Rubygems Puma: from 5.0.0 before 5.6.2; before 4.3.11; 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.1.0 (+138) — fixed in 5.6.2, 4.3.11
How to fix
Upgrade to a fixed version: puma 4.3.11, 5.6.2; Ruby on Rails 5.2.6.2, 6.0.4.6, 6.1.4.6, 7.0.2.2; Rubygems Puma 5.6.2, 4.3.11. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-rmj8-8hhh-gv5h
- https://github.com/advisories/GHSA-wh98-p28r-vrc9
- https://github.com/puma/puma/commit/b70f451fe8abc0cff192c065d549778452e155bb
- https://github.com/puma/puma/security/advisories/GHSA-rmj8-8hhh-gv5h
- https://groups.google.com/g/ruby-security-ann/c/FkTM-_7zSNA/m/K2RiMJBlBAAJ?utm_medium=email&utm_source=footer&pli=1
- https://lists.debian.org/debian-lts-announce/2022/05/msg00034.html
- https://lists.debian.org/debian-lts-announce/2022/08/msg00015.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/F6YWGIIKL7KKTS3ZOAYMYPC7D6WQ5OA5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L7NESIBFCNSR3XH7LXDPKVMSUBNUB43G/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TUBFJ44NCKJ34LECZRAP4N5VL6USJSIB/
- https://security.gentoo.org/glsa/202208-28
- https://www.debian.org/security/2022/dsa-5146
Get alerted when CVE-2022-23634 or the next vulnerability affects your stack