What’s Vulnerable › Vulnerabilities
CVE-2022-23638: Cross-site Scripting in svg-sanitizer
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.
Affected products
- darylldoyle svg-sanitizer: before 0.15.0 — fixed in 0.15.0
How to fix
Upgrade to a fixed version: darylldoyle svg-sanitizer 0.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/darylldoyle/svg-sanitizer/commit/17e12ba9c2881caa6b167d0fbea555c11207fbb0
- https://github.com/darylldoyle/svg-sanitizer/security/advisories/GHSA-fqx8-v33p-4qcc
- https://github.com/darylldoyle/svg-sanitizer/commit/17e12ba9c2881caa6b167d0fbea555c11207fbb0
- https://github.com/darylldoyle/svg-sanitizer/security/advisories/GHSA-fqx8-v33p-4qcc
Get alerted when CVE-2022-23638 or the next vulnerability affects your stack