What’s Vulnerable › Vulnerabilities
CVE-2022-23639: Improper Restriction of Operations within the Bounds of a Memory Buffer and Race Condition in crossbeam-utils
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-15 · updated 2026-06-17
- Weakness: CWE-362
Description
crossbeam-utils provides atomics, synchronization primitives, scoped threads, and other utilities for concurrent programming in Rust. crossbeam-utils prior to version 0.8.7 incorrectly assumed that the alignment of `{i,u}64` was always the same as `Atomic{I,U}64`. However, the alignment of `{i,u}64` on a 32-bit target can be smaller than `Atomic{I,U}64`. This can cause unaligned memory accesses and data race. Crates using `fetch_*` methods with `AtomicCell<{i,u}64>` are affected by this issue. 32-bit targets without `Atomic{I,U}64` and 64-bit targets are not affected by this issue. This has been fixed in crossbeam-utils 0.8.7. There are currently no known workarounds.
Affected products
- crossbeam-rs crossbeam: before 0.8.7 — fixed in 0.8.7
How to fix
Upgrade to a fixed version: crossbeam-rs crossbeam 0.8.7. Check the vendor advisory for mitigations.
References
- https://github.com/crossbeam-rs/crossbeam/pull/781
- https://github.com/crossbeam-rs/crossbeam/releases/tag/crossbeam-utils-0.8.7
- https://github.com/crossbeam-rs/crossbeam/security/advisories/GHSA-qc84-gqf4-9926
- https://github.com/crossbeam-rs/crossbeam/pull/781
- https://github.com/crossbeam-rs/crossbeam/releases/tag/crossbeam-utils-0.8.7
- https://github.com/crossbeam-rs/crossbeam/security/advisories/GHSA-qc84-gqf4-9926
Get alerted when CVE-2022-23639 or the next vulnerability affects your stack