What’s Vulnerable › Vulnerabilities
CVE-2022-23641: Denial of Service in Discourse
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-15 · updated 2026-06-17
- Weakness: CWE-835
Description
Discourse is an open source discussion platform. In versions prior to 2.8.1 in the `stable` branch, 2.9.0.beta2 in the `beta` branch, and 2.9.0.beta2 in the `tests-passed` branch, users can trigger a Denial of Service attack by posting a streaming URL. Parsing Oneboxes in the background job trigger an infinite loop, which cause memory leaks. This issue is patched in version 2.8.1 of the `stable` branch, 2.9.0.beta2 of the `beta` branch, and 2.9.0.beta2 of the `tests-passed` branch. As a workaround, disable onebox in admin panel completely or specify allow list of domains that will be oneboxed.
Affected products
- discourse: before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: discourse 2.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/a34075d205a8857e29574ffd82aaece0c467565e
- https://github.com/discourse/discourse/pull/15927
- https://github.com/discourse/discourse/security/advisories/GHSA-22xw-f62v-cfxv
- https://github.com/discourse/discourse/commit/a34075d205a8857e29574ffd82aaece0c467565e
- https://github.com/discourse/discourse/pull/15927
- https://github.com/discourse/discourse/security/advisories/GHSA-22xw-f62v-cfxv
Get alerted when CVE-2022-23641 or the next vulnerability affects your stack