What’s Vulnerable › Vulnerabilities
CVE-2022-23644: Server-side request forgery in BookWyrm
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-16 · updated 2026-06-17
- Weakness: CWE-918
Description
BookWyrm is a decentralized social network for tracking reading habits and reviewing books. The functionality to load a cover via url is vulnerable to a server-side request forgery attack. Any BookWyrm instance running a version prior to v0.3.0 is susceptible to attack from a logged-in user. The problem has been patched and administrators should upgrade to version 0.3.0 As a workaround, BookWyrm instances can close registration and limit members to trusted individuals.
Affected products
- bookwyrm-social bookwyrm: before 0.3.0 — fixed in 0.3.0
How to fix
Upgrade to a fixed version: bookwyrm-social bookwyrm 0.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-5m7g-66h6-5cvq
- https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-5m7g-66h6-5cvq
Get alerted when CVE-2022-23644 or the next vulnerability affects your stack