What’s Vulnerable › Vulnerabilities
CVE-2022-23646: Improper CSP in Image Optimization API for Next.js
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-17 · updated 2026-06-17
- Weakness: CWE-451
Description
Next.js is a React framework. Starting with version 10.0.0 and prior to version 12.1.0, Next.js is vulnerable to User Interface (UI) Misrepresentation of Critical Information. In order to be affected, the `next.config.js` file must have an `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default, the instance is not affected. Version 12.1.0 contains a patch for this issue. As a workaround, change `next.config.js` to use a different `loader configuration` other than the default.
Affected products
- Next.js: from 10.0.0 before 12.1.0 — fixed in 12.1.0
How to fix
Upgrade to a fixed version: Next.js 12.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/pull/34075
- https://github.com/vercel/next.js/releases/tag/v12.1.0
- https://github.com/vercel/next.js/security/advisories/GHSA-fmvm-x8mv-47mj
- https://github.com/vercel/next.js/pull/34075
- https://github.com/vercel/next.js/releases/tag/v12.1.0
- https://github.com/vercel/next.js/security/advisories/GHSA-fmvm-x8mv-47mj
Get alerted when CVE-2022-23646 or the next vulnerability affects your stack