What’s Vulnerable › Vulnerabilities
CVE-2022-23647: Cross-site Scripting in Prism
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.
Affected products
- PrismJS prism: from 1.14.0 before 1.27.0 — fixed in 1.27.0
How to fix
Upgrade to a fixed version: PrismJS prism 1.27.0. Check the vendor advisory for mitigations.
References
- https://github.com/PrismJS/prism/commit/e002e78c343154e1c0ddf9d6a0bb85689e1a5c7c
- https://github.com/PrismJS/prism/pull/3341
- https://github.com/PrismJS/prism/security/advisories/GHSA-3949-f494-cm99
- https://github.com/PrismJS/prism/commit/e002e78c343154e1c0ddf9d6a0bb85689e1a5c7c
- https://github.com/PrismJS/prism/pull/3341
- https://github.com/PrismJS/prism/security/advisories/GHSA-3949-f494-cm99
Get alerted when CVE-2022-23647 or the next vulnerability affects your stack