What’s Vulnerable › Vulnerabilities
CVE-2022-23648: Insecure handling of image volumes in containerd CRI plugin
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-03 · updated 2026-06-17
- Weakness: CWE-200
Description
containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.
Affected products
- Debian Linux: 11.0
- Fedoraproject Fedora: 34, 35, 36
- containerd: before 1.4.13; from 1.5.0 before 1.5.10; from 1.6.0 before 1.6.1 — fixed in 1.4.13, 1.5.10, 1.6.1
How to fix
Upgrade to a fixed version: containerd 1.4.13, 1.5.10, 1.6.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/166421/containerd-Image-Volume-Insecure-Handling.html
- https://github.com/containerd/containerd/commit/10f428dac7cec44c864e1b830a4623af27a9fc70
- https://github.com/containerd/containerd/releases/tag/v1.4.13
- https://github.com/containerd/containerd/releases/tag/v1.5.10
- https://github.com/containerd/containerd/releases/tag/v1.6.1
- https://github.com/containerd/containerd/security/advisories/GHSA-crp2-qrr5-8pq7
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AUDQUQBZJGBWJPMRVB6QCCCRF7O3O4PA/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HFTS2EF3S7HNYSNZSEJZIJHPRU7OPUV3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OCCARJ6FU4MWBTXHZNMS7NELPDBIX2VO/
- https://security.gentoo.org/glsa/202401-31
- https://www.debian.org/security/2022/dsa-5091
- http://packetstormsecurity.com/files/166421/containerd-Image-Volume-Insecure-Handling.html
Get alerted when CVE-2022-23648 or the next vulnerability affects your stack