What’s Vulnerable › Vulnerabilities
CVE-2022-2365: Cross-site Scripting (XSS) - Stored in zadam/trilium
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository zadam/trilium prior to 0.53.3.
Affected products
- zadam/trilium: before 0.53.3 — fixed in 0.53.3
How to fix
Upgrade to a fixed version: zadam/trilium 0.53.3. Check the vendor advisory for mitigations.
References
- https://github.com/zadam/trilium/commit/1dfc37704fdd90ab7afbd8a586bdfc5cfaadeb8a
- https://huntr.dev/bounties/34b281cd-ff4a-4ab0-ae25-56aef557682f
- https://github.com/zadam/trilium/commit/1dfc37704fdd90ab7afbd8a586bdfc5cfaadeb8a
- https://huntr.dev/bounties/34b281cd-ff4a-4ab0-ae25-56aef557682f
Get alerted when CVE-2022-2365 or the next vulnerability affects your stack