What’s Vulnerable › Vulnerabilities
CVE-2022-23684
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-06 · updated 2026-06-17
Description
A vulnerability in the web-based management interface of AOS-CX could allow a remote authenticated user with read-only privileges to escalate their permissions to those of an administrative user. Successful exploitation of this vulnerability allows an attacker to escalate privileges beyond their authorized level in ArubaOS-CX Switches version(s): AOS-CX 10.09.xxxx: 10.09.1020 and below, AOS-CX 10.08.xxxx: 10.08.1060 and below, AOS-CX 10.06.xxxx: 10.06.0200 and below. Aruba has released upgrades for ArubaOS-CX Switch Devices that address this security vulnerability.
Affected products
- Aruba CX 6200F Switch Series; Aruba 6300 Switch Series; Aruba 6400 Switch Series; Aruba 8325 Switch Series; Aruba 8400 S: from 10.06.0000 before 10.06.0210; from 10.08.0000 before 10.08.1070; from 10.09.0000 before 10.09.1030 — fixed in 10.06.0210, 10.08.1070, 10.09.1030
How to fix
Upgrade to a fixed version: Aruba CX 6200F Switch Series; Aruba 6300 Switch Series; Aruba 6400 Switch Series; Aruba 8325 Switch Series; Aruba 8400 S 10.06.0210, 10.08.1070, 10.09.1030. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2022-012.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2022-012.txt
Get alerted when CVE-2022-23684 or the next vulnerability affects your stack