What’s Vulnerable › Vulnerabilities
CVE-2022-2370: YaySMTP < 2.2.1 - Subscriber+ SMTP Credentials Leak
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-862
Description
The YaySMTP WordPress plugin before 2.2.1 does not have capability check before displaying the Mailer Credentials in JS code for the settings, allowing any authenticated users, such as subscriber to retrieve them
Affected products
- YaySMTP – Simple WP SMTP Mail: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: YaySMTP – Simple WP SMTP Mail 2.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bedda2a9-6c52-478e-b17a-7a4488419334
- https://wpscan.com/vulnerability/bedda2a9-6c52-478e-b17a-7a4488419334
Get alerted when CVE-2022-2370 or the next vulnerability affects your stack