What’s Vulnerable › Vulnerabilities
CVE-2022-23703
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-12 · updated 2026-06-17
Description
A security vulnerability has been identified in HPE Nimble Storage Hybrid Flash Arrays, HPE Nimble Storage All Flash Arrays and HPE Nimble Storage Secondary Flash Arrays during update. This would potentially allow an attacker to intercept and modify network communication for software updates initiated by the Nimble appliance. The following NimbleOS versions, and all subsequent releases, contain a software fix for this vulnerability: 5.0.10.100, 5.2.1.500, 6.0.0.100
Affected products
- HPE Nimbleos: before 5.0.10.100; from 5.1.0.0 before 5.2.1.500; 5.3.1.0 — fixed in 5.0.10.100, 5.2.1.500
How to fix
Upgrade to a fixed version: HPE Nimbleos 5.0.10.100, 5.2.1.500. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst04268en_us
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst04268en_us
Get alerted when CVE-2022-23703 or the next vulnerability affects your stack