What’s Vulnerable › Vulnerabilities
CVE-2022-23708
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-03 · updated 2026-06-17
- Weakness: CWE-264
Description
A flaw was discovered in Elasticsearch 7.17.0’s upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built protections on the security index, allowing authenticated users with “*” index permissions access to this index.
Affected products
- Elasticsearch: from 7.16.0 before 7.17.1 — fixed in 7.17.1
How to fix
Upgrade to a fixed version: Elasticsearch 7.17.1. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-7-17-1-security-update/298447
- https://security.netapp.com/advisory/ntap-20220729-0003/
- https://discuss.elastic.co/t/elastic-stack-7-17-1-security-update/298447
- https://security.netapp.com/advisory/ntap-20220729-0003/
Get alerted when CVE-2022-23708 or the next vulnerability affects your stack