What’s Vulnerable › Vulnerabilities
CVE-2022-2371: YaySMTP < 2.2.1 - Subscriber+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The YaySMTP WordPress plugin before 2.2.1 does not have proper authorisation when saving its settings, allowing users with a role as low as subscriber to change them, and use that to conduct Stored Cross-Site Scripting attack due to the lack of escaping in them as well.
Affected products
- YaySMTP – Simple WP SMTP Mail: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: YaySMTP – Simple WP SMTP Mail 2.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/31405f1e-fc07-43f5-afc1-9cfbaf6911b7
- https://wpscan.com/vulnerability/31405f1e-fc07-43f5-afc1-9cfbaf6911b7
Get alerted when CVE-2022-2371 or the next vulnerability affects your stack