What’s Vulnerable › Vulnerabilities
CVE-2022-23712
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-06 · updated 2026-06-17
- Weakness: CWE-754
Description
A Denial of Service flaw was discovered in Elasticsearch. Using this vulnerability, an unauthenticated attacker could forcibly shut down an Elasticsearch node with a specifically formatted network request.
Affected products
- Elasticsearch: from 8.0.0 before 8.2.1 — fixed in 8.2.1
How to fix
Upgrade to a fixed version: Elasticsearch 8.2.1. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-7-17-4-and-8-2-1-security-update/305530
- https://security.netapp.com/advisory/ntap-20220707-0010/
- https://www.elastic.co/community/security/
- https://discuss.elastic.co/t/elastic-stack-7-17-4-and-8-2-1-security-update/305530
- https://security.netapp.com/advisory/ntap-20220707-0010/
- https://www.elastic.co/community/security/
Get alerted when CVE-2022-23712 or the next vulnerability affects your stack