What’s Vulnerable › Vulnerabilities
CVE-2022-2372: YaySMTP < 2.2.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The YaySMTP WordPress plugin before 2.2.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- YaySMTP – Simple WP SMTP Mail: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: YaySMTP – Simple WP SMTP Mail 2.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/941fadb6-0009-4751-b979-88e87ebb1e45
- https://wpscan.com/vulnerability/941fadb6-0009-4751-b979-88e87ebb1e45
Get alerted when CVE-2022-2372 or the next vulnerability affects your stack