What’s Vulnerable › Vulnerabilities

CVE-2022-23737: Improper Privilege Management in GitHub Enterprise Server leading to page creation and deletion

Description

An improper privilege management vulnerability was identified in GitHub Enterprise Server that allowed users with improper privileges to create or delete pages via the API. To exploit this vulnerability, an attacker would need to be added to an organization's repo with write permissions. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.7 and was fixed in versions 3.2.20, 3.3.15, 3.4.10, 3.5.7, and 3.6.3. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.2.20, 3.3.15, 3.4.10, 3.5.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-23737 or the next vulnerability affects your stack