What’s Vulnerable › Vulnerabilities
CVE-2022-2374: Simply Schedule Appointments < 1.5.7.7 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Simply Schedule Appointments WordPress plugin before 1.5.7.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin: before 1.5.7.7 — fixed in 1.5.7.7
How to fix
Upgrade to a fixed version: Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin 1.5.7.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/12062d78-7a0d-4dc1-9bd6-6c54aa6bc761
- https://wpscan.com/vulnerability/12062d78-7a0d-4dc1-9bd6-6c54aa6bc761
Get alerted when CVE-2022-2374 or the next vulnerability affects your stack