What’s Vulnerable › Vulnerabilities
CVE-2022-23743
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-11 · updated 2026-06-17
- Weakness: CWE-269
Description
Check Point ZoneAlarm before version 15.8.200.19118 allows a local actor to escalate privileges during the upgrade process. In addition, weak permissions in the ProgramData\CheckPoint\ZoneAlarm\Data\Updates directory allow a local attacker the ability to execute an arbitrary file write, leading to execution of code as local system, in ZoneAlarm versions before v15.8.211.192119
Affected products
- Check Point ZoneAlarm: before 15.8.211.192119 — fixed in 15.8.211.192119
How to fix
Upgrade to a fixed version: Check Point ZoneAlarm 15.8.211.192119. Check the vendor advisory for mitigations.
References
- https://www.zonealarm.com/software/extreme-security/release-history
- https://www.zonealarm.com/software/extreme-security/release-history
Get alerted when CVE-2022-23743 or the next vulnerability affects your stack