What’s Vulnerable › Vulnerabilities
CVE-2022-2375: WP Sticky Button < 1.4.1 - Unauthenticated Arbitrary Settings Update to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Sticky Button WordPress plugin before 1.4.1 does not have authorisation and CSRF checks when saving its settings, allowing unauthenticated users to update them. Furthermore, due to the lack of escaping in some of them, it could lead to Stored Cross-Site Scripting issues
Affected products
- WP Sticky Button – Click to Chat: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: WP Sticky Button – Click to Chat 1.4.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/caab1fca-cc6b-45bb-bd0d-f857edd8bb81
- https://wpscan.com/vulnerability/caab1fca-cc6b-45bb-bd0d-f857edd8bb81
Get alerted when CVE-2022-2375 or the next vulnerability affects your stack