What’s Vulnerable › Vulnerabilities
CVE-2022-2377: Directorist < 7.3.0 - Subscriber+ Arbitrary E-mail Sending
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-352
Description
The Directorist WordPress plugin before 7.3.0 does not have authorisation and CSRF checks in an AJAX action, allowing any authenticated users to send arbitrary emails on behalf of the blog
Affected products
- wpwax Directorist: AI-Powered Business Directory, Listings & Classified Ads: before 7.3.0 — fixed in 7.3.0
How to fix
Upgrade to a fixed version: wpwax Directorist: AI-Powered Business Directory, Listings & Classified Ads 7.3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f4e606e9-0664-42fb-a59b-21de306eb530
- https://wpscan.com/vulnerability/f4e606e9-0664-42fb-a59b-21de306eb530
Get alerted when CVE-2022-2377 or the next vulnerability affects your stack