What’s Vulnerable › Vulnerabilities

CVE-2022-23773

Description

cmd/go in Go before 1.16.14 and 1.17.x before 1.17.7 can misinterpret branch names that falsely appear to be version tags. This can lead to incorrect access control if an actor is supposed to be able to create branches but not tags.

Affected products

How to fix

Upgrade to a fixed version: Go 1.16.14, 1.17.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-23773 or the next vulnerability affects your stack