What’s Vulnerable › Vulnerabilities
CVE-2022-23810
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-94
Description
Template injection (Improper Neutralization of Special Elements Used in a Template Engine) vulnerability in a-blog cms Ver.2.8.x series versions prior to Ver.2.8.75, Ver.2.9.x series versions prior to Ver.2.9.40, Ver.2.10.x series versions prior to Ver.2.10.44, Ver.2.11.x series versions prior to Ver.2.11.42, and Ver.3.0.x series versions prior to Ver.3.0.1 allows a remote authenticated attacker to obtain an arbitrary file on the server via unspecified vectors.
Affected products
- appleple inc. a-blog cms: from 2.8.0 before 2.8.75; from 2.9.0 before 2.9.40; from 2.10.0 before 2.10.44; from 2.11.0 before 2.11.42; 3.0.0 — fixed in 2.10.44, 2.11.42, 2.8.75, 2.9.40
How to fix
Upgrade to a fixed version: appleple inc. a-blog cms 2.10.44, 2.11.42, 2.8.75, 2.9.40. Check the vendor advisory for mitigations.
References
- https://developer.a-blogcms.jp/blog/news/security-202202.html
- https://jvn.jp/en/jp/JVN14706307/index.html
- https://developer.a-blogcms.jp/blog/news/security-202202.html
- https://jvn.jp/en/jp/JVN14706307/index.html
Get alerted when CVE-2022-23810 or the next vulnerability affects your stack