What’s Vulnerable › Vulnerabilities
CVE-2022-23837: Denial of service in sidekiq
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-21 · updated 2026-06-17
- Weakness: CWE-770
Description
In api.rb in Sidekiq before 5.2.10 and 6.4.0, there is no limit on the number of days when requesting stats for the graph. This overloads the system, affecting the Web UI, and makes it unavailable to users.
Affected products
- sidekiq/sidekiq: before 5.2.10; from 6.0.0 before 6.4.0 — fixed in 5.2.10, 6.4.0
- Debian Linux: 9.0
- Rubygems Sidekiq: from 6.0.0 before 6.4.0; before 5.2.10; 6.0.0, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.0.5 (+163) — fixed in 6.4.0, 5.2.10
How to fix
Upgrade to a fixed version: sidekiq/sidekiq 5.2.10, 6.4.0; Rubygems Sidekiq 6.4.0, 5.2.10. Check the vendor advisory for mitigations.
References
- https://github.com/TUTUMSPACE/exploits/blob/main/sidekiq.md
- https://github.com/mperham/sidekiq/commit/7785ac1399f1b28992adb56055f6acd88fd1d956
- https://github.com/rubysec/ruby-advisory-db/pull/495
- https://lists.debian.org/debian-lts-announce/2022/03/msg00015.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00011.html
- https://github.com/TUTUMSPACE/exploits/blob/main/sidekiq.md
- https://github.com/mperham/sidekiq/commit/7785ac1399f1b28992adb56055f6acd88fd1d956
- https://github.com/rubysec/ruby-advisory-db/pull/495
- https://lists.debian.org/debian-lts-announce/2022/03/msg00015.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00011.html
Get alerted when CVE-2022-23837 or the next vulnerability affects your stack