What’s Vulnerable › Vulnerabilities
CVE-2022-23852
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-24 · updated 2026-10-14
- Weakness: CWE-190
Description
Expat (aka libexpat) before 2.4.4 has a signed integer overflow in XML_GetBuffer, for configurations with a nonzero XML_CONTEXT_BYTES.
Affected products
- Debian Linux: 9.0
- libexpat project libexpat: before 2.4.4 — fixed in 2.4.4
- Clustered Data ONTAP: all versions
- NetApp OnCommand Workflow Automation: all versions
- Oracle Communications Metasolv Solution: 6.3.1
- Siemens SINEMA Remote Connect Server: before 3.1 — fixed in 3.1
- Tenable Nessus: before 8.15.3; from 10.0.0 before 10.1.1 — fixed in 10.1.1, 8.15.3
How to fix
Upgrade to a fixed version: libexpat project libexpat 2.4.4; Siemens SINEMA Remote Connect Server 3.1; Tenable Nessus 10.1.1, 8.15.3. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-484086.pdf
- https://github.com/libexpat/libexpat/pull/550
- https://lists.debian.org/debian-lts-announce/2022/03/msg00007.html
- https://security.gentoo.org/glsa/202209-24
- https://security.netapp.com/advisory/ntap-20220217-0001/
- https://www.debian.org/security/2022/dsa-5073
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.tenable.com/security/tns-2022-05
- https://cert-portal.siemens.com/productcert/pdf/ssa-484086.pdf
- https://github.com/libexpat/libexpat/pull/550
- https://lists.debian.org/debian-lts-announce/2022/03/msg00007.html
- https://security.gentoo.org/glsa/202209-24
Get alerted when CVE-2022-23852 or the next vulnerability affects your stack