What’s Vulnerable › Vulnerabilities
CVE-2022-23853
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-11 · updated 2026-06-17
- Weakness: CWE-427
Description
The LSP (Language Server Protocol) plugin in KDE Kate before 21.12.2 and KTextEditor before 5.91.0 tries to execute the associated LSP server binary when opening a file of a given type. If this binary is absent from the PATH, it will try running the LSP server binary in the directory of the file that was just opened (due to a misunderstanding of the QProcess API, that was never intended). This can be an untrusted directory.
Affected products
- KDE Kate: before 21.12.2 — fixed in 21.12.2
- KDE Ktexteditor: before 5.91.0 — fixed in 5.91.0
How to fix
Upgrade to a fixed version: KDE Kate 21.12.2; KDE Ktexteditor 5.91.0. Check the vendor advisory for mitigations.
References
- https://apps.kde.org/kate/
- https://kde.org/info/security/advisory-20220131-1.txt
- https://security.gentoo.org/glsa/202401-21
- https://apps.kde.org/kate/
- https://kde.org/info/security/advisory-20220131-1.txt
- https://security.gentoo.org/glsa/202401-21
Get alerted when CVE-2022-23853 or the next vulnerability affects your stack