What’s Vulnerable › Vulnerabilities
CVE-2022-2388: WP Coder < 2.5.3 - Code Deletion via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Coder WordPress plugin before 2.5.3 does not have CSRF check in place when deleting code created by the plugin, which could allow attackers to make a logged in admin delete arbitrary ones via a CSRF attack
Affected products
- WP Coder – add custom html, css and js code: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: WP Coder – add custom html, css and js code 2.5.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/50acd35f-eb31-4aba-bf32-b390e9514beb
- https://wpscan.com/vulnerability/50acd35f-eb31-4aba-bf32-b390e9514beb
Get alerted when CVE-2022-2388 or the next vulnerability affects your stack