What’s Vulnerable › Vulnerabilities
CVE-2022-2391: Inspiro Pro < 7.2.3 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Inspiro PRO WordPress plugin does not sanitize the portfolio slider description, allowing users with privileges as low as Contributor to inject JavaScript into the description.
Affected products
- Inspiro PRO: before 7.2.3 — fixed in 7.2.3
How to fix
Upgrade to a fixed version: Inspiro PRO 7.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/dd6ebf6b-209b-437c-9fe4-527ab9e3b9e3
- https://wpscan.com/vulnerability/dd6ebf6b-209b-437c-9fe4-527ab9e3b9e3
Get alerted when CVE-2022-2391 or the next vulnerability affects your stack