What’s Vulnerable › Vulnerabilities
CVE-2022-23911: AP Custom Testimonial < 1.4.8 - Admin+ SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-89
Description
The Testimonial WordPress Plugin WordPress plugin before 1.4.7 does not validate and escape the id parameter before using it in a SQL statement when retrieving a testimonial to edit, leading to a SQL Injection
Affected products
- Testimonial WordPress Plugin – AP Custom Testimonial: before 1.4.7 — fixed in 1.4.7
How to fix
Upgrade to a fixed version: Testimonial WordPress Plugin – AP Custom Testimonial 1.4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2664185
- https://wpscan.com/vulnerability/77fd6749-4fb2-48fa-a191-437b442f28e9
- https://plugins.trac.wordpress.org/changeset/2664185
- https://wpscan.com/vulnerability/77fd6749-4fb2-48fa-a191-437b442f28e9
Get alerted when CVE-2022-23911 or the next vulnerability affects your stack