What’s Vulnerable › Vulnerabilities
CVE-2022-23912: AP Custom Testimonial < 1.4.8 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The Testimonial WordPress Plugin WordPress plugin before 1.4.7 does not sanitise and escape the id parameter before outputting it back in an attribute, leading to a Reflected cross-Site Scripting
Affected products
- Testimonial WordPress Plugin – AP Custom Testimonial: before 1.4.7 — fixed in 1.4.7
How to fix
Upgrade to a fixed version: Testimonial WordPress Plugin – AP Custom Testimonial 1.4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2664185
- https://wpscan.com/vulnerability/09512431-aa33-4514-8b20-1963c5d89f33
- https://plugins.trac.wordpress.org/changeset/2664185
- https://wpscan.com/vulnerability/09512431-aa33-4514-8b20-1963c5d89f33
Get alerted when CVE-2022-23912 or the next vulnerability affects your stack