What’s Vulnerable › Vulnerabilities
CVE-2022-23915: Remote Code Execution (RCE)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-04 · updated 2026-06-17
- Weakness: CWE-88
Description
The package weblate from 0 and before 4.11.1 are vulnerable to Remote Code Execution (RCE) via argument injection when using git or mercurial repositories. Authenticated users, can change the behavior of the application in an unintended way, leading to command execution.
Affected products
- WeblateOrg weblate: before 4.11.1 — fixed in 4.11.1
How to fix
Upgrade to a fixed version: WeblateOrg weblate 4.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/WeblateOrg/weblate/pull/7337
- https://github.com/WeblateOrg/weblate/pull/7338
- https://github.com/WeblateOrg/weblate/releases/tag/weblate-4.11.1
- https://snyk.io/vuln/SNYK-PYTHON-WEBLATE-2414088
- https://github.com/WeblateOrg/weblate/pull/7337
- https://github.com/WeblateOrg/weblate/pull/7338
- https://github.com/WeblateOrg/weblate/releases/tag/weblate-4.11.1
- https://snyk.io/vuln/SNYK-PYTHON-WEBLATE-2414088
Get alerted when CVE-2022-23915 or the next vulnerability affects your stack