What’s Vulnerable › Vulnerabilities
CVE-2022-2394: Sensitive Parameter Exposure in Puppet Bolt prior to 3.24
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-19 · updated 2026-06-17
- Weakness: CWE-200
Description
Puppet Bolt prior to version 3.24.0 will print sensitive parameters when planning a run resulting in them potentially being logged when run programmatically, such as via Puppet Enterprise.
Affected products
- Perforce Puppet Bolt: before 3.24.0 — fixed in 3.24.0
How to fix
Upgrade to a fixed version: Perforce Puppet Bolt 3.24.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-2394 or the next vulnerability affects your stack