What’s Vulnerable › Vulnerabilities
CVE-2022-23948
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-21 · updated 2026-06-17
- Weakness: CWE-200
Description
A flaw was found in Keylime before 6.3.0. The logic in the Keylime agent for checking for a secure mount can be fooled by previously created unprivileged mounts allowing secrets to be leaked to other processes on the host.
Affected products
- keylime: before 6.3.0 — fixed in 6.3.0
How to fix
Upgrade to a fixed version: keylime 6.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/keylime/keylime/commit/1a4f31a6368d651222683c9debe7d6832db6f607
- https://github.com/keylime/keylime/commit/d37c406e69cb6689baa2fb7964bad75209703724
- https://github.com/keylime/keylime/security/advisories/GHSA-wj36-qcfg-5j52
- https://seclists.org/oss-sec/2022/q1/101
- https://github.com/keylime/keylime/commit/1a4f31a6368d651222683c9debe7d6832db6f607
- https://github.com/keylime/keylime/commit/d37c406e69cb6689baa2fb7964bad75209703724
- https://github.com/keylime/keylime/security/advisories/GHSA-wj36-qcfg-5j52
- https://seclists.org/oss-sec/2022/q1/101
Get alerted when CVE-2022-23948 or the next vulnerability affects your stack