What’s Vulnerable › Vulnerabilities
CVE-2022-23949
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-21 · updated 2026-06-17
- Weakness: CWE-290
Description
In Keylime before 6.3.0, unsanitized UUIDs can be passed by a rogue agent and can lead to log spoofing on the verifier and registrar.
Affected products
- keylime: before 6.3.0 — fixed in 6.3.0
How to fix
Upgrade to a fixed version: keylime 6.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/keylime/keylime/commit/387e320dc22c89f4f47c68cb37eb9eec2137f34b
- https://github.com/keylime/keylime/commit/65c2b737129b5837f4a03660aeb1191ced275a57
- https://github.com/keylime/keylime/commit/e429e95329fc60608713ddfb82f4a92ee3b3d2d9
- https://github.com/keylime/keylime/security/advisories/GHSA-87gh-qc28-j9mm
- https://seclists.org/oss-sec/2022/q1/101
- https://github.com/keylime/keylime/commit/387e320dc22c89f4f47c68cb37eb9eec2137f34b
- https://github.com/keylime/keylime/commit/65c2b737129b5837f4a03660aeb1191ced275a57
- https://github.com/keylime/keylime/commit/e429e95329fc60608713ddfb82f4a92ee3b3d2d9
- https://github.com/keylime/keylime/security/advisories/GHSA-87gh-qc28-j9mm
- https://seclists.org/oss-sec/2022/q1/101
Get alerted when CVE-2022-23949 or the next vulnerability affects your stack