What’s Vulnerable › Vulnerabilities
CVE-2022-2395: weForms < 1.6.14 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The weForms WordPress plugin before 1.6.14 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- boldgrid weForms – Easy Drag & Drop Contact Form Builder For WordPress: before 1.6.14 — fixed in 1.6.14
How to fix
Upgrade to a fixed version: boldgrid weForms – Easy Drag & Drop Contact Form Builder For WordPress 1.6.14. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5e442dd9-a49d-4a8e-959b-199a8689da4b
- https://wpscan.com/vulnerability/5e442dd9-a49d-4a8e-959b-199a8689da4b
Get alerted when CVE-2022-2395 or the next vulnerability affects your stack