What’s Vulnerable › Vulnerabilities
CVE-2022-23959
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-26 · updated 2026-06-17
- Weakness: CWE-444
Description
In Varnish Cache before 6.6.2 and 7.x before 7.0.2, Varnish Cache 6.0 LTS before 6.0.10, and and Varnish Enterprise (Cache Plus) 4.1.x before 4.1.11r6 and 6.0.x before 6.0.9r4, request smuggling can occur for HTTP/1 connections.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 35
- varnish-software Varnich Cache: from 1.0.0 before 6.6.2; from 4.1.1 before 4.1.11r6; 4.1 — fixed in 4.1.11r6, 6.6.2
- varnish-software Varnish Cache: from 6.0.0 before 6.0.10 — fixed in 6.0.10
- varnish-software Varnish Cache Plus: from 6.0.0 before 6.0.9r4 — fixed in 6.0.9r4
- Varnish Cache Project Varnish Cache: from 7.0.0 before 7.0.2 — fixed in 7.0.2
How to fix
Upgrade to a fixed version: varnish-software Varnich Cache 4.1.11r6, 6.6.2; varnish-software Varnish Cache 6.0.10; varnish-software Varnish Cache Plus 6.0.9r4; Varnish Cache Project Varnish Cache 7.0.2. Check the vendor advisory for mitigations.
References
- https://docs.varnish-software.com/security/VSV00008/
- https://lists.debian.org/debian-lts-announce/2022/02/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UMMDMQWNAE3BTSZUHXQHVAMZC5TLHLYT/
- https://varnish-cache.org/security/VSV00008.html
- https://www.debian.org/security/2022/dsa-5088
- https://docs.varnish-software.com/security/VSV00008/
- https://lists.debian.org/debian-lts-announce/2022/02/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UMMDMQWNAE3BTSZUHXQHVAMZC5TLHLYT/
- https://varnish-cache.org/security/VSV00008.html
- https://www.debian.org/security/2022/dsa-5088
Get alerted when CVE-2022-23959 or the next vulnerability affects your stack