What’s Vulnerable › Vulnerabilities
CVE-2022-23987: WS Form < 1.8.176 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WS Form LITE and Pro WordPress plugins before 1.8.176 do not sanitise and escape their Form Name, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- westguard WS Form LITE – Drag & Drop Contact Form Builder: before 1.8.176 — fixed in 1.8.176
How to fix
Upgrade to a fixed version: westguard WS Form LITE – Drag & Drop Contact Form Builder 1.8.176. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1697351b-c201-4e85-891e-94fdccbdfb55
- https://wpscan.com/vulnerability/1697351b-c201-4e85-891e-94fdccbdfb55
Get alerted when CVE-2022-23987 or the next vulnerability affects your stack