What’s Vulnerable › Vulnerabilities
CVE-2022-23988: WS Form < 1.8.176 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WS Form LITE and Pro WordPress plugins before 1.8.176 do not sanitise and escape submitted form data, allowing unauthenticated attacker to submit XSS payloads which will get executed when a privileged user will view the related submission
Affected products
- westguard WS Form LITE – Drag & Drop Contact Form Builder: before 1.8.176 — fixed in 1.8.176
How to fix
Upgrade to a fixed version: westguard WS Form LITE – Drag & Drop Contact Form Builder 1.8.176. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9d5738f9-9a2e-4878-8a03-745894420bf6
- https://wpscan.com/vulnerability/9d5738f9-9a2e-4878-8a03-745894420bf6
Get alerted when CVE-2022-23988 or the next vulnerability affects your stack