What’s Vulnerable › Vulnerabilities
CVE-2022-23993
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-26 · updated 2026-06-17
- Weakness: CWE-79
Description
/usr/local/www/pkg.php in pfSense CE before 2.6.0 and pfSense Plus before 22.01 uses $_REQUEST['pkg_filter'] in a PHP echo call, causing XSS.
Affected products
- Netgate pfSense CE: before 2.6.0 — fixed in 2.6.0
- Netgate pfSense Plus: before 22.01 — fixed in 22.01
How to fix
Upgrade to a fixed version: Netgate pfSense CE 2.6.0; Netgate pfSense Plus 22.01. Check the vendor advisory for mitigations.
References
- https://docs.netgate.com/downloads/pfSense-SA-22_04.webgui.asc
- https://github.com/pfsense/pfsense/commit/5d82cce0d615a76b738798577a28a15803e59aeb
- https://docs.netgate.com/downloads/pfSense-SA-22_04.webgui.asc
- https://github.com/pfsense/pfsense/commit/5d82cce0d615a76b738798577a28a15803e59aeb
Get alerted when CVE-2022-23993 or the next vulnerability affects your stack