What’s Vulnerable › Vulnerabilities
CVE-2022-2401: Team members could access sensitive information of other users via an API call
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-14 · updated 2026-06-17
- Weakness: CWE-200
Description
Unrestricted information disclosure of all users in Mattermost version 6.7.0 and earlier allows team members to access some sensitive information by directly accessing the APIs.
Affected products
- Mattermost: before 6.3.9; from 6.4.0 before 6.5.2; 6.6.0, 6.6.1, 6.7.0 — fixed in 6.3.9, 6.5.2
How to fix
Upgrade to a fixed version: Mattermost 6.3.9, 6.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-2401 or the next vulnerability affects your stack