What’s Vulnerable › Vulnerabilities
CVE-2022-2404: WP Popup Builder < 1.2.9 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Popup Builder WordPress plugin before 1.2.9 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting
Affected products
- WP Popup Builder – Popup Forms , Marketing PoPuP & Newsletter: before 1.2.9 — fixed in 1.2.9
How to fix
Upgrade to a fixed version: WP Popup Builder – Popup Forms , Marketing PoPuP & Newsletter 1.2.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0d889dde-b9d5-46cf-87d3-4f8a85cf9b98
- https://wpscan.com/vulnerability/0d889dde-b9d5-46cf-87d3-4f8a85cf9b98
Get alerted when CVE-2022-2404 or the next vulnerability affects your stack