What’s Vulnerable › Vulnerabilities
CVE-2022-24044
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-307
Description
A vulnerability has been identified in Desigo DXR2 (All versions < V01.21.142.5-22), Desigo PXC3 (All versions < V01.21.142.4-18), Desigo PXC4 (All versions < V02.20.142.10-10884), Desigo PXC5 (All versions < V02.20.142.10-10884). The login functionality of the application does not employ any countermeasures against Password Spraying attacks or Credential Stuffing attacks. An attacker could obtain a list of valid usernames on the device by exploiting the issue and then perform a precise Password Spraying or Credential Stuffing attack in order to obtain access to at least one account.
Affected products
- Siemens Desigo Dxr2 Firmware: before 01.21.142.5-22 — fixed in 01.21.142.5-22
- Siemens Desigo Pxc3 Firmware: before 01.21.142.4-18 — fixed in 01.21.142.4-18
- Siemens Desigo Pxc4 Firmware: before 02.20.142.10-10884 — fixed in 02.20.142.10-10884
- Siemens Desigo Pxc5 Firmware: before 02.20.142.10-10884 — fixed in 02.20.142.10-10884
How to fix
Upgrade to a fixed version: Siemens Desigo Dxr2 Firmware 01.21.142.5-22; Siemens Desigo Pxc3 Firmware 01.21.142.4-18; Siemens Desigo Pxc4 Firmware 02.20.142.10-10884; Siemens Desigo Pxc5 Firmware 02.20.142.10-10884. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-626968.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-626968.pdf
Get alerted when CVE-2022-24044 or the next vulnerability affects your stack