What’s Vulnerable › Vulnerabilities
CVE-2022-24062
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-18 · updated 2026-06-17
- Weakness: CWE-416
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Sante DICOM Viewer Pro 13.2.0.21165. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of JP2 files. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-15104.
Affected products
- Sante DICOM Viewer Pro: before 11.9.2 — fixed in 11.9.2
How to fix
Upgrade to a fixed version: Sante DICOM Viewer Pro 11.9.2. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-22-254/
- https://www.zerodayinitiative.com/advisories/ZDI-22-254/
Get alerted when CVE-2022-24062 or the next vulnerability affects your stack