What’s Vulnerable › Vulnerabilities
CVE-2022-2407: WP phpMyAdmin < 5.2.0.4 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP phpMyAdmin WordPress plugin before 5.2.0.4 does not escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- WP phpMyAdmin: before 5.2.0.4 — fixed in 5.2.0.4
How to fix
Upgrade to a fixed version: WP phpMyAdmin 5.2.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5be611e8-5b7a-4579-9757-45a4c94a53ca
- https://wpscan.com/vulnerability/5be611e8-5b7a-4579-9757-45a4c94a53ca
Get alerted when CVE-2022-2407 or the next vulnerability affects your stack