What’s Vulnerable › Vulnerabilities
CVE-2022-24070: Apache Subversion mod_dav_svn is vulnerable to memory corruption
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-12 · updated 2026-06-17
- Weakness: CWE-416
Description
Subversion's mod_dav_svn is vulnerable to memory corruption. While looking up path-based authorization rules, mod_dav_svn servers may attempt to use memory which has already been freed. Affected Subversion mod_dav_svn servers 1.10.0 through 1.14.1 (inclusive). Servers that do not use mod_dav_svn are not affected.
Affected products
- Apache Software Foundation Apache Subversion: from 1.10.0 before 1.10.8; from 1.14.0 before 1.14.2 — fixed in 1.10.8, 1.14.2
- Apple macOS: from 12.0 before 12.5 — fixed in 12.5
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 35, 36
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Subversion 1.10.8, 1.14.2; Apple macOS 12.5. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Jul/18
- https://bz.apache.org/bugzilla/show_bug.cgi?id=65861
- https://cwiki.apache.org/confluence/display/HTTPD/ModuleLife
- https://issues.apache.org/jira/browse/SVN-4880
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PZ4ARNGLMGYBKYDX2B7DRBNMF6EH3A6R/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YJPMCWCGWBN3QWCDVILWQWPC75RR67LT/
- https://support.apple.com/kb/HT213345
- https://www.debian.org/security/2022/dsa-5119
- http://seclists.org/fulldisclosure/2022/Jul/18
- https://bz.apache.org/bugzilla/show_bug.cgi?id=65861
- https://cwiki.apache.org/confluence/display/HTTPD/ModuleLife
- https://issues.apache.org/jira/browse/SVN-4880
Get alerted when CVE-2022-24070 or the next vulnerability affects your stack