What’s Vulnerable › Vulnerabilities
CVE-2022-24074
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-17 · updated 2026-06-17
- Weakness: CWE-668
Description
Whale Bridge, a default extension in Whale browser before 3.12.129.18, allowed to receive any SendMessage request from the content script itself that could lead to controlling Whale Bridge if the rendering process compromises.
Affected products
- NAVER Whale browser: before 3.12.129.18 — fixed in 3.12.129.18
How to fix
Upgrade to a fixed version: NAVER Whale browser 3.12.129.18. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-24074 or the next vulnerability affects your stack