What’s Vulnerable › Vulnerabilities
CVE-2022-24093: Adobe Commerce post-auth improper input validation leads to remote code execution
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-12 · updated 2026-06-17
- Weakness: CWE-20
Description
Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.
Affected products
- Adobe Commerce: before 2.3.7; from 2.4.0 before 2.4.3; 2.3.7-p1, 2.3.7-p2, 2.4.3, 2.4.3-p1 — fixed in 2.3.7, 2.4.3
- Adobe Magento Open Source: before 2.3.7; from 2.4.0 before 2.4.3; 2.3.7-p1, 2.3.7-p2, 2.4.3, 2.4.3-p1 — fixed in 2.3.7, 2.4.3
How to fix
Upgrade to a fixed version: Adobe Commerce 2.3.7, 2.4.3; Adobe Magento Open Source 2.3.7, 2.4.3. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb22-13.html
- https://helpx.adobe.com/security/products/magento/apsb22-13.html
Get alerted when CVE-2022-24093 or the next vulnerability affects your stack